Вопрос по информатике:
Составьте программу на Паскале.Даны три различных вещественных числа,найти среднее из них.Среднее число- это такое , которое больше наименьшего из данных чисел,но меньше наибольшего.
- 07.01.2018 01:29
- Информатика
- remove_red_eye 8078
- thumb_up 35
Ответы и объяснения 2
//Pascal ABC.NET 3.1 сборка 1219
Var
a,b,c:real;
begin
read(a,b,c);
if ((a>b) and (a
Пример ввода:
1.1
1.2
1.3
Пример вывода:
1.2
- 08.01.2018 05:53
- thumb_up 7
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
var a,b,c:real;
Write('Введите три числа: '); Read(a,b,c);
Print('Среднее из чисел:');
Seq(a,b,c).Sorted.Skip(1).Take(1).Println;
end.
Тестовое решение
Введите три числа: 5.3 2.8 10
Среднее из чисел: 5.3
- 09.01.2018 19:45
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.