Вопрос по информатике:
Помогите пожалуйста,на языке PascalABC.Net:
2) Разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. Дано действительное число х, натуральное число n. Написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1!+x^2/2!+x^3/3!+...+x^n/n!
- 04.12.2017 03:41
- Информатика
- remove_red_eye 13493
- thumb_up 48
Ответы и объяснения 1
//PascalABC.NET 3.1 сборка 1239
begin
var x := ReadReal('x =');
var s := 0.0;
var a := 1.0;
for var i := 1 to ReadInteger('n =') do
begin
a *= x / i;
s += a;
end;
writeln(s);
end.
- 05.12.2017 07:12
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.