Вопрос по информатике:
Пожалуйста, срочно помогите написать программу в Pascal ABC для вычисления среднего гармонического значения элементов массива Х (N), кратных двум. При этом даны ограничения, что xi>0, N<30. N должно выбираться через генератор случайных чисел Random и Randomize.
- 10.09.2017 18:05
- Информатика
- remove_red_eye 7666
- thumb_up 15
Ответы и объяснения 1
Var
a: array[1..100] of integer;
i, n: integer;
harmonic: real;
k: integer;
begin
Randomize;
n := random(20) + 10;
for i := 1 to n do
begin
a[i] := random(50);
write(a[i], ' ');
end;
writeln();
harmonic := 1;
k := 0;
for i := 1 to n do
begin
if a[i] mod 2 = 0 then {фильтр}
begin
harmonic := harmonic + 1 / a[i];
k := k + 1;
end;
end;
writeln('harmonic mean = ', k / harmonic);
end.
- 11.09.2017 18:31
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.