Вопрос по информатике:
Составьте программу заполнения массива из 100 целых чисел случайными числами от 1 до 20 и найти сумму четных чисел
- 08.08.2017 19:16
- Информатика
- remove_red_eye 8985
- thumb_up 27
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
var a:=ArrRandom(100,1,20); a.Println;
Writeln('Сумма четных чисел равна ',a.Where(x->x.IsEven).Sum)
end.
Тестовое решение
7 9 17 2 1 18 8 9 9 3 14 13 10 18 20 5 5 9 5 18 20 12 6 19 2 3 20 17 9 15 3 2 18 17 16 8 5 11 7 15 19 11 17 15 18 18 12 17 12 11 11 11 15 9 20 16 3 19 1 18 18 12 1 14 20 12 16 14 2 13 1 15 3 11 19 9 16 12 2 4 12 3 5 19 4 12 7 10 17 1 5 7 11 9 17 7 11 3 16 6
Сумма четных чисел равна 528
- 09.08.2017 23:46
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.