Вопрос по информатике:
На языке С или С++ написать программу . Натуральное число называется числом Армстронга, если сумма цифр числа, возве-денных в N-ную степень (где N – количество цифр в числе) равна самому числу. Например, 153 = 13 + 53 + 33. Найдите все трёхзначные Армстронга.
- 11.08.2017 20:02
- Информатика
- remove_red_eye 7578
- thumb_up 44
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int n,s;
for (int i=100; i<=999; i++)
{
n = i % 10;
s = n*n*n;
n = i / 10 % 10;
s = s+n*n*n;
n = i /100;
s = s+n*n*n;
if (i == s) cout << i << "\n";
}
return 0;
}
Результат:
153
370
371
407
- 12.08.2017 20:23
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.