Вопрос по информатике:
На языке СИ. Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B.
Пример:
Введите два целых числа:
10 12
10*10=100
11*11=121
12*12=144
- 25.09.2017 12:03
- Информатика
- remove_red_eye 19071
- thumb_up 26
Ответы и объяснения 1
#include
#include
using namespace std;
int main()
{
setlocale(LC_ALL,"Russian");
unsigned long long A,B;
cout << "Введите A(Начало) и B(Конец):\t";
cin >> A >> B;
if (A>0)
for (unsigned long long i=A; i<=B; i++)
cout << i << "\t - \t" << i*i << endl;
else
{
cout << "Ошибка!";
_getch();
return -1;
}
_getch();
return 0;
}
P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.
- 26.09.2017 06:54
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.