- 07.03.2018 01:11
- Информатика
- remove_red_eye 6409
- thumb_up 36
Ответы и объяснения 1
#include
//входные данные#define n 4#define m 3
int main(){ //Входные данныеfloat a[n] = { 2.1, 3.2, 4.8, 5.7 };
float b = 18; float sqrt_b = sqrt(b); float c[m] = { 15, 25, 25 };
//результат float y = 0; //временная переменная float tmp; printf("\n y = sum(1;%d){a[i] + sqrt(b)} + mng(1;%d){sin(c)}", n, m);
//Подсчет суммы tmp = 0; int i = -1; while (++i < n) tmp += (a[i] + sqrt_b); //Запись в результат y += tmp;
//Подсчет произведения tmp = 1; i = -1; while (++i < m) tmp *= (sin(c[i])); //Запись в результат y += tmp;
//Вывод printf(" \n >> y = %g\n",y);
system("pause>>void"); return 0;}
- 08.03.2018 03:26
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.