Вопрос по информатике:
Составить блок-схему и написать программу на языке PascalABC.NET.
1. Даны действительные положительные числа x, y, z. Выяснить, существует ли треугольник с длинами сторон x, y, z.
2. Даны три действительных числа. Выбрать из них те, которые принадлежат интервалу (1, 3).
- 21.04.2017 02:49
- Информатика
- remove_red_eye 11690
- thumb_up 46
Ответы и объяснения 1
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x
Программа:
var x, y, z: real;
begin
writeln('Введите стороны треугольника x, y, z: ');
read(x, y, z);
if (x + y > z) and (x + z > y) and (y + z > x)
then writeln('Треугольник существует')
else writeln('Треугольник не существует');
end.
2. Думаю, здесь излишни объяснения.
Программа:
var x, y, z: real;
begin
writeln('Введите три числа: ');
read(x, y, z);
writeln('В интервале (1; 3) лежат числа: ');
if (x > 1) and (x < 3) then writeln(x);
if (y > 1) and (y < 3) then writeln(y);
if (z > 1) and (z < 3) then writeln(z);
end.
Блок-схемы в приложении:
- 22.04.2017 16:19
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.