Вопрос по информатике:
Написать программу, которая проверяет, является ли введенная с клавиатуры строка дробным числом.
На Паскале
- 02.08.2018 17:29
- Информатика
- remove_red_eye 1510
- thumb_up 6
Ответы и объяснения 1
// Программа на паскале
var
s: string;
k, i: integer;
begin
readln(s);
k := pos(',', s);
if (k < 2) or (k = length(s)) then writeln('No')
else
begin
for i := 1 to length(s) do
if (i k) and ((s[i] '9')) then
begin
writeln('No');
exit
end;
writeln('Yes');
end;
end.
Примеры работы программы:
Ввод Вывод
1,6 Yes
123, No
,49 No
0,758 Yes
- 03.08.2018 23:42
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.