Вопрос по информатике:
Составить программу определения значений указанных ниже параметров линейного массива. Выполнить программу для длины массива N=8. Сумма положительных элементов массива. Си++
- 23.09.2017 11:37
- Информатика
- remove_red_eye 1339
- thumb_up 49
Ответы и объяснения 1
#include
using namespace std;
const int N = 8; //длина массива
int s = 0; //начальное значение суммы
int mas[N]; //объявляем статический массив длины N
int main()
{
//вводим элементы массива
for(int i = 0; i < N; ++i)
{
cin >> mas[i];
}
//пробегаемся по элементам массива
for(int i = 0; i < N; ++i)
{
if(mas[i] > 0) //если элемент массива больше 0
s += mas[i]; //прибавляем значение элемента к итоговой сумме
}
cout << s; //вывод суммы на экран
return 0;
}
- 24.09.2017 07:25
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.