Вопрос по информатике:
С объяснением:)
1) Найдите значение логического выражения, если x=-3, y=3, z=-5 и D=false
F:=not((x<0) and (y<0)) or ((z<-2) and D))
2) Разработать алгоритм и программу линейной структуры.
a=lg|x+1|, y=∛5a²-3x², x=3; z=-4,972
3) Дан фрагмент программы:
a:=5; b:=8; c:=-2;
while(a<b) do a:=a+1; c:=c+1; writeln('c=',c);
Чему равно значение c=?
4) Дан фрагмент программы:
SetColor(red); Setfillstyle(1,2); SetBkcolor(15); Circle(200,200,50);
Каким цветом закрашена область, ограниченная ... (укажите код цвета)?
5) Дан фрагмент программы.
Var s:string; n:integer;
Begin s:='Досвидания'; n:=length(s); writeln('n='); end.
Чему равно значение n?
- 08.10.2015 19:24
- Информатика
- remove_red_eye 17996
- thumb_up 18
Ответы и объяснения 1
1) в расстановке скобок здесь ошибка, в решении показан один из возможных вариантов исправления этой ошибки:
F:=not((x<0) and (y<0)) or ((z<-2) and D) ⇒
not((-3<0) and (3<0)) or ((-5<-2) and false) ⇒
not(true and false) or (true and false) ⇒ not false or false ⇒ true or false ⇒ true
2) здесь тоже в условии что-то не то (z - лишняя переменная получается) и корень из чего извлекать - тоже непонятно
var x,a,y:real;
begin
x:=3;
a:=ln(abs(x+1))/ln(10);
y:=exp(ln(5)*(1/3))*a*a-3*x*x;
writeln('y = ',y);
end.
Результат:
y = -26.3801743600581
3)
a=5; b=8; c=-2;
aaaac=c+1=-2+1=-1
Ответ: c=-1
4)
SetColor(red); - устанавливается цвет рисования (красный)
Setfillstyle(1,2); - устанавливается стиль заливки (1 - заполнение текущим цветом, 2 - зеленый цвет)
SetBkcolor(15); - устанавливается цвет фона (15-белый; экран сразу же окрашивается в заданный цвет)
Circle(200,200,50); - рисуется окружность (центр 200, 200; радиус 50)
О какой области спрашивается - непонятно.
5)
n- длина строки s (количество символов в строке) n = 10 (пробела после 'До' нет)
- 09.10.2015 10:12
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.