Вопрос по информатике:
Написать программу в Паскаль.
Дан массив целых чисел. Найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное. Выведите также сформированный массив и все искомые пары соседних элементов.
- 05.08.2018 07:48
- Информатика
- remove_red_eye 8345
- thumb_up 46
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
var b:=a.Pairwise; b.Println;
Writeln('Найдено пар: ',
b.Where(x->(x[0]<0) and x[1].IsEven or
(x[1]<0) and x[0].IsEven).Count)
end.
Тестовое решение
n= 10
-37 -71 -71 -65 73 -66 -33 -85 62 -92
(-37,-71) (-71,-71) (-71,-65) (-65,73) (73,-66) (-66,-33) (-33,-85) (-85,62) (62,-92)
Найдено пар: 3
- 06.08.2018 13:17
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.