Вопрос по информатике:
Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд. Количество минут и секунд при необходимости дополняются до двузначного числа нулями.
С начала суток прошло n секунд. Выведите, что покажут часы.
Входные данные
Вводится целое число n.
Выходные данные
Выведите ответ на задачу, соблюдая требуемый формат.
Примеры
входные данные
3602
выходные данные
1:00:02
входные данные
129700
выходные данные
12:01:40
- 15.11.2017 14:16
- Информатика
- remove_red_eye 13997
- thumb_up 8
Ответы и объяснения 1
Var
n, h, m, s: integer;
begin
read(n);
n := n mod (3600*24);
h := n div 3600;
m := n mod 3600 div 60;
s := n mod 60;
write(h div 10, h mod 10, ':', m div 10, m mod 10, ':', s div 10, s mod 10);
end.
- 16.11.2017 02:57
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.