Вопрос по информатике:
С адекватным объяснением!
1) дан фрагмент программы:
var s:string[6]; n:integer;
begin
s:='отлично';
n:=length(s);
writeln('n=');
end.
2) Дан фрагмент программы:
Setcolor(red);
Setfillstyle(1,2);
setbkcolor(15);
sector(200,200,90,270,50,50);
Нарисуйте полученную фигуру.
3) Дан фрагмент программы:
var s,s1:string; n:integer;
begin
s:='информатика';
s1:=copy(s,3,5);
n:=pos(s,s1);
writeln('n=');
end.
чему равно значение n?
- 20.12.2017 18:27
- Информатика
- remove_red_eye 4466
- thumb_up 13
Ответы и объяснения 1
1)
var
s: string[6];
n: integer;
begin
s := 'отлично';
n := length(s);
writeln(length('отлично'));
writeln(n);
end.
Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
Ответ 6
2) рисунок
3)var
s, s1: string;
n: integer;
begin
s := 'информатика';
s1 := copy(s, 3, 5);
n := pos(s, s1);
writeln('s=', s);
writeln('s1=', s1);
writeln('n=', n);
end.
Вывод
s=информатика
s1=форма
n=0
Все верно, в s1 не содержится s, а наоборот
- 21.12.2017 21:02
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.