Вопрос по информатике:
Вы — большой любитель бактерий. Вам хочется вырастить немного бактерий в коробочке.
Изначально коробочка пуста. Каждое утро можно положить любое количество бактерий в коробочку. Каждую ночь каждая бактерия делится на две бактерии. Когда-нибудь вы надеетесь увидеть ровно x бактерий в коробочке.
Какое минимальное количество бактерий вам суммарно надо положить в коробочку для достижения этой цели?
Входные данные
В единственной строке записано одно целое число x (1 ≤ x ≤ 109) — количество бактерий.
Выходные данные
Единственная строка, содержащая одно целое число — ответ на задачу.
- 12.02.2018 21:09
- Информатика
- remove_red_eye 7446
- thumb_up 28
Ответы и объяснения 1
#include #include
int main(void){ int count, result = 0; scanf ("%d", &count); while (count) { if (count & 1) result++; count >>= 1; } printf ("%d\n", result); return 0;}
- 13.02.2018 05:57
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.