Вопрос по информатике:
Напишите программу, которая спрашивала бы сокращенное имя, а печатала полное для пяти ваших друзей. Ввод незнакомого имени должен провоцировать заявление типа «Я С ВАМИ НЕЗНАКОМА
- 15.07.2018 00:57
- Информатика
- remove_red_eye 15461
- thumb_up 31
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
var names:array[1..2,1..5] of string:=
(('Саша','Женя','Таня','Лена','Вася'),
('Александр','Евгений','Татьяна','Елена','Василий'));
var name:=ReadlnString('Введите краткое имя:');
var p:=0;
for var i:=1 to 5 do
if name=names[1,i] then begin p:=i; break end;
if p>0 then Writeln(names[2,p])
else Writeln('Я вас не знаю!')
end.
Тестовое решение
Введите краткое имя: Лена
Елена
- 15.07.2018 06:49
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.