Вопрос по информатике:
Доброго времени суток! Пожалуйста, помогите написать программу на С++ для решения задачи.
Дано целое число n. Выведите следующее за ним четное число. При решении этой задачи нельзя использовать условную инструкцию if и циклы.
Входные данные
Вводится целое число.
Выходные данные
Выведите ответ на задачу.
- 20.12.2017 10:39
- Информатика
- remove_red_eye 18327
- thumb_up 30
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int n, m;
cout <> n, cout << "\n";
m = n + 1 + (n+1)%2;
cout << "m = " << m;
return 0;
}
Пример:
n = 17
m = 18
- 21.12.2017 20:25
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.