Вопрос по информатике:
Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N. Простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число.
- 24.11.2017 05:51
- Информатика
- remove_red_eye 3094
- thumb_up 40
Ответы и объяснения 1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 uses crt; var i,n: integer; function IsSimple(c: integer): boolean; var j: integer; begin IsSimple:=true; for j:=2 to c-1 do if c mod j=0 then IsSimple:=false; end; begin write('n='); readln(n); for i:=2 to n do if IsSimple(i) then write(i,' '); end.
- 25.11.2017 19:37
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.