Вопрос по информатике:
56) Получив на вход число х, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 15.
var x, a, b: integer;
begin
readln(x);
a := 0; b := 0;
while x > 0 do begin
a := a+1;
b := b+(x mod 100);
x := x div 100;
end;
writeln(a); write(b);
end.
- 08.05.2018 19:15
- Информатика
- remove_red_eye 11389
- thumb_up 7
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.