Вопрос по информатике:
1.Определите значение переменной k:
Str1:=’abcd’; Str2:=’abc’; k:=Pos (Str1,Str2);
2.Чему будет равно значение величины x, после выполнения последовательности операторов:
st:='ABCDEFG' ;
x:=copy(st, 4, 10);
3.Истинно или ложно утверждение: Под величину типа string отводиться 256 байт.
4.Определите значение переменной S2:
S1:=’ABCD’; S2:=’abcd’; Insert (S1, S2, 2);
5.Истинно или ложно утверждение: Величины типа string можно сравнивать между собой.
6.Определите значение переменной S1:
S1:=’мышь’; Delete (S1, 4, 1); Insert (‘ка’, S1, 4);
7.Что будет выведено на экран в результате работы программы?
const a: array[1..8] of char = 'abcrcaab' ;
var i: integer; k: string;
begin
k:=' ';
for i:=8 downto 2 do if a[i]<'c' then k:=k+a[i]; writeln(k);
end.
8.Чему будет равно значение величины st, после выполнения последовательности операторов:
st:='абвгде' ;
delete(st,4,2);
9.Определите значение переменной k:
S:=’компьютер’; Delete (S, 5, 6); k:=Length (S);
10.Чему будет равен результат выполнения функции:
concat('AA', 'XX', 'YY');
11.Чему будет равен результат d, после выполнения последовательности операторов:
st:='System 370' ;
d:=length(st);
12.Истинно или ложно утверждение: Результат сравнения величин типа string имеет тип string.
13.Определите значение переменной k:
k:=0; Str:=’abcabc’;
For i:=1 To Length (Str) Do
if Str[i]=’b’ Then Inc (k);
14.Истинно или ложно утверждение: Величины типа string можно вычитать друг из друга.
15.Для обозначения строкового типа в Delphi используется зарезервированное слово:
16.Чему будет равен результат, после выполнения последовательности операторов:
st1:='ЕС' ;
st2:='ЭВМ1841' ;
insert(st1, st2, 4);
17.Чему будет равен результат n выполнения последовательности операторов:
st:='abcdef' ;
n:=pos('de', st);
18.Определите значение переменной k:
Str1:=’abc’; Str2:=Copy (Str1, 2, 3); k:=Length (Str1);
19.Вместо знака ? поставьте правильный знак сравнения двух строк “<” или “>”
'Boy' ? 'Girl'
20.Вместо знака ? поставьте правильный знак сравнения двух строк “<” или “>”
'Alexei' ? 'Sergei'
21.Истинно или ложно утверждение: Величины типа string можно складывать друг с другом.
22.Определите значение переменной k:
k:=0; S:=’123mnMN’;
For i:=1 To Length (S) Do
if (S[i] >= ’a’) and (S[i] <= ’z’) Then k:=k + 1;
23.Вместо знака ? поставьте правильный знак сравнения двух строк “<” или “>”
'110' ? '100'
24.Определите значение переменной k:
S:=’’; For i:=1 To 5 Do
S:=S + ‘a’; k:=Length (S);
25.Определите значение переменной k:
S:=’237-234’; Val(S, k);
- 16.01.2018 20:36
- Информатика
- remove_red_eye 18308
- thumb_up 27
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.