Вопрос по информатике:
ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3.
- 19.08.2015 01:50
- Информатика
- remove_red_eye 4458
- thumb_up 22
Ответы и объяснения 2
Var
n,a,i,s:integer;
begin
readln(n);
s:=0;
for i:=1 to n do
begin
readln(a);
if a mod 3=0 then
s:=s+a;
end;
writeln(s);
end.
- 20.08.2015 22:43
- thumb_up 4
//Pascal ABC.NET 3.1
begin
var n:=readinteger();
var ar:=readArrInteger(n);
writeln(ar.where(x -> x mod 3=0).sum);
end.
- 21.08.2015 22:55
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.