Вопрос по информатике:
Помогите пожалуйста составить программу:
Найти наибольшее значение функции y=ax в квадрате+bx+c на отрезке [x1,x2]
- 04.06.2015 22:06
- Информатика
- remove_red_eye 6980
- thumb_up 14
Ответы и объяснения 2
Var
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
- 05.06.2015 11:34
- thumb_up 42
Var
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.
- 06.06.2015 13:51
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.