Вопрос по информатике:
Дан массив из 20 натуральных чисел. Составить программу суммы элементов, кратных данному числу d .
- 13.09.2018 12:24
- Информатика
- remove_red_eye 15273
- thumb_up 35
Ответы и объяснения 1
Const
n=20;
var a:array[1..n] of integer;
var i,d,s:integer;
begin
s:=0;
writeln('Введите число d');
readln(d);
writeln('Введите массив');
for i:=1 to n do begin
read(a[i]);
if a[i] mod d = 0 then s:=s+a[i];
end;
writeln(s);
end.
- 14.09.2018 12:22
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.