Вопрос по информатике:
Напишите программу на паскале
А.выясните какие числа ввел пользователь: положительное или отрицательное?
Б.выясните какие числа ввел пользователь: четное или нечетное ?
- 24.01.2016 07:46
- Информатика
- remove_red_eye 14479
- thumb_up 18
Ответы и объяснения 2
Var x:integer;
begin
writeln('Введите число');
readln(x);
if x>0 then write('Число положительное и ')
else write('Число отрицательное и ');
if x mod 2=0 then write('четное.')
else writeln('нечетное');
end.
- 25.01.2016 22:36
- thumb_up 40
//Pascal ABC.NET v3.1 сборка 1219
Var
n:integer;
begin
readln(n);
if n>0 then writeln('Положительное');
if n<0 then writeln('Отрицательное');
if n=0 then writeln('0');
if n mod 2=0 then writeln('Чётное') else writeln('Нечётное');
end.
Пример ввода:
1
Пример вывода:
Положительное
Нечётное
- 26.01.2016 17:21
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.