Вопрос по информатике:
Каждое утро майор Знаменский идет в тир и делает пять выстрелов через плечо. Если он набирает 50 очков, то вечером идет с Зиночкой в ресторан, а если меньше, то на тренировку в тир. Написать программу, которая выдает планы майора на вечер.В паскале
- 27.04.2016 07:07
- Информатика
- remove_red_eye 777
- thumb_up 10
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1219
//Как я понял, количество очков случайно
Var
a,i,s:integer;
begin
randomize;
for i:=1 to 5 do
begin
a:=random(11);
writeln(i,' выстрел -',a);
s:=s+a;
end;
writeln('Сумма=',s);
if s=50 then writeln('Идет с Зиночкой в ресторан') else writeln('На тренировку в тир');
end.
Пример работы программы:
1 выстрел -3
2 выстрел -10
3 выстрел -7
4 выстрел -8
5 выстрел -0
Сумма=28
На тренировку в тир
- 28.04.2016 04:07
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.