Вопрос по информатике:
Задача 4.Напишите программу ,которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел,не превосходящих 256.Программа получает на выход целые числа ,количество введенных чисел неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность.)Количество чисел не превышает 1000.Введенные числа по модулю не превышают 30 000.Программа должна вывести два числа:длину последовательности и сумму положительных чётных чисел,не превосходящих 256.
- 25.04.2018 00:03
- Информатика
- remove_red_eye 10666
- thumb_up 22
Ответы и объяснения 1
Var x,k:integer;
begin
k:=0;
repeat
writeln('Введите число');
read(x);
if (x>0) and (x<=256) then k:=k+1;
until x=0;
writeln('Количество положительных чисел <=256 = ',k);
end.
- 25.04.2018 19:53
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.