Вопрос по информатике:
Дан массив, состоящий из чисел: a1=5; a2=3; a3=8; a4=2; a5=10; a6=7; a7=20; a8=1 . Напишите программу нахождения минимального из них. Нужно использовать Паскаль
- 09.09.2017 23:57
- Информатика
- remove_red_eye 12937
- thumb_up 15
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
const
n=8;
var
i,min:integer;
a:array[1..n] of integer;
begin
Writeln('Введите ',n,' чисел: ');
min:=10000;
for i:=1 to n do begin
Read(a[i]);
if min>a[i] then min:=a[i]
end;
Writeln('Минимальное введенное число равно ',min)
end.
Тестовое решение
Введите 8 чисел:
5 3 8 2 10 7 20 1
Минимальное введенное число равно 1
- 01.01.1970 00:00
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.