Вопрос по информатике:
Массив arr[6] заполнен единицами. Написать программу, которая используя датчик случайных целых чисел, получает на каждом шаге цикла случайное значение индекса массива х и выполняет операцию arr[x]=0. Найти среднее число, при котором все значения элементов массива будут заменены на нули.
- 01.05.2018 16:17
- Информатика
- remove_red_eye 4294
- thumb_up 17
Ответы и объяснения 1
Var arr:array [1..6] of integer;i,k,x,s,d,j:integer;beginrandomize;d:=0;for j:=1 to 1000 dobeginfor i:=1 to 6 do arr[i]:=1;k:=1;s:=1;while k0 do begin x:=random(6)+1; arr[x]:=0; if (arr[1]=0) and (arr[2]=0) and (arr[3]=0) and (arr[4]=0) and(arr[5]=0) and (arr[6]=0) then k:=0; s:=s+1; end;d:=d+s; end;Writeln('В среднем цикл отработал ',d/1000,' раз'); end.
В среднем цикл отработал 15.946 разПри многократном запуске получается около 16 раз
- 02.05.2018 18:34
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.