Вопрос по информатике:
Напишите программу перевода двоичного числа 10101001011 в десятичную СС в Паскале АВС
- 21.05.2016 16:12
- Информатика
- remove_red_eye 2270
- thumb_up 27
Ответы и объяснения 1
//PascalABC.NET 3.1 сборка 1239
function BinToDec(bin: string): integer;
begin
var n := 0;
var p := 1;
for var i := length(bin) downto 1 do
begin
n += p * StrToInt(bin[i]);
p *= 2;
end;
Result := n;
end;
begin
var s := ReadlnString('s =');
writeln(BinToDec(s));
end.
- 22.05.2016 12:49
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.