Вопрос по информатике:
Напишите программу, которая впоследовательности целых чиселопределяет количество четных чисел,кратных шести. Программа получает на вход целые числа, количество введенныхчисел неизвестно, последовательностьчисел заканчивается числом ноль (ноль – признак окончания ввода, не входит впоследовательность) . Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000.
- 17.06.2017 19:57
- Информатика
- remove_red_eye 1917
- thumb_up 45
Ответы и объяснения 1
Const N = 1000;var a: array [1..N] of integer;k,i,C:integer;beginreadln (C);k:=0;for i:=1 to C do readln (a[i]);for i:= 1 to C do begin while a[i]0 do if (a[i] mod 2 = 0) and (a[i] mod 6 = 0) then k:=k+1 end;writeln (k); end.
- 18.06.2017 07:37
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.