Вопрос по информатике:
Здравствуйте! Прошу помощи по информатике нужно написать программу.
" Пользователь вводит текст. Посчитать количество предложений и слов в этом тексте."
program go;
var s1:string;
a,i,k,b:integer;
begin
writeln('Введите текст');
begin;
readln(s1);
a:=length(s1);
if a>0 then begin
b:=1;
while a>0 do begin
if s1[i]='b' then
b:=b+1;
i:=i-1;
end;
end
else
b:=0;
writeln('Количество слов в тексте',b);
end;
begin;
readln(s1);
a:=length(s1);
for i:=1 to a do
if s1[i]='.' then
if s1[i+1]=' ' then
k:=k+1;
end;
writeln('В тексте ',k,' предложений..');
end.
при выполнени и моей выдает ошибку выполнения времени. Индекс находится вне границ массива..
- 22.09.2018 10:31
- Информатика
- remove_red_eye 19155
- thumb_up 31
Ответы и объяснения 1
Var s: string;
i,k,c: integer;
begin
write('Введите текст: ');
readln(s);
i := length(s);
k:=0;
for i:=1 to length(s) do
if s[i] in ['.','?','!'] then inc(k);
if i > 0 then begin
c := 1;
while i > 0 do begin
if s[i] = ' ' then
inc(c);
dec(i);
end;
end
else
c := 0;
writeln('Количество слов в тексте: ', c);
writeln('Количество предложений в тексте: ', k);
end.
- 24.09.2018 00:03
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.