Вопрос по информатике:
Составьте программу определения наибольшего общего делителя двух натуральных чисел.
на абс паскале плис,.очень надо
- 22.03.2018 03:03
- Информатика
- remove_red_eye 10798
- thumb_up 17
Ответы и объяснения 1
Var a,b,NOD:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
while (a0)and(b0) do
if a>b then a:=a mod b else b:=b mod a;
NOD:=a+b;
writeln('НОД=',NOD);
end.
Пример:
a=75
b=125
НОД=25
- 24.03.2018 00:32
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.