Вопрос по информатике:
Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом работы программы является последовательность чисел заканчивающихся ( по гипотезе Сиракуза) единицей.
- 06.05.2015 03:55
- Информатика
- remove_red_eye 19695
- thumb_up 21
Ответы и объяснения 1
Var
a, b, n, i: integer;
begin
readln(a, b);
for i := a to b do
begin
n := i;
write(n);
while n 1 do
begin
if (n mod 2) = 0 then
n := n div 2
else
n := (3 * n + 1) div 2;
write(' -> ', n);
end;
writeln;
end;
end.
чесно передрано с некого сайта и доработано под задачу
- 07.05.2015 09:03
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.