Вопрос по информатике:
Помогите,пожалуйста!информатика,10 класс,Паскаль
1)Написать программу.Вводятся два двухзначных целых числа.Подсчитать и вывести два числа:сумма десятков первого и второго числа и сумма единиц первого и второго числа.
2)Вводятся два двухзначных целых числа.Подсчитать и вывести два числа:произведение десятков первого числа и единиц второго числа;произведение единиц первого числа и десятков второго.
3)Вводятся два двухзначных целых числа.Подсчитать и вывести два числа:произведение десятков первого числа и единиц второго числа;сумма единиц первого числа и десятков второго числа.
- 10.12.2017 07:48
- Информатика
- remove_red_eye 2215
- thumb_up 28
Ответы и объяснения 1
Первая программа.
Program d_and_e;
Var
a,b,sum_d,sum_e:integer;
Begin
WriteLn('введите первое число: ');
ReadLn(a);
WriteLn('введите второеое число: ');
ReadLn(b);
sum_d:=(a div 10) + (b div 10);
sum_e:=(a mod 10) + (b mod 10);
WriteLn('сумма десятков чисел: ', sum_d);
WriteLn('сумма единиц чисел: ', sum_e);
end.
Вторая программа.
Program d_and_e;
Var
a,b,mult_d1_e2,mult_e1_d2:integer;
Begin
WriteLn('введите первое число: ');
ReadLn(a);
WriteLn('введите второе число: ');
ReadLn(b);
mult_d1_e2:=(a div 10) * (b mod 10);
mult_e1_d2:=(a mod 10) * (b div 10);
WriteLn('произведение десятков 1-го и единиц 2-го числа: ', mult_d1_e2);
WriteLn('произведение единиц 1-го и десятков 2-го числа: ', mult_e1_d2);
end.
Третья программа.
Program d_and_e;
Var
a,b,mult_d1_e2,sum_e1_d2:integer;
Begin
WriteLn('введите первое число: ');
ReadLn(a);
WriteLn('введите второе число: ');
ReadLn(b);
mult_d1_e2:=(a div 10) * (b mod 10);
sum_e1_d2:=(a mod 10) + (b div 10);
WriteLn('произведение десятков 1-го и единиц 2-го числа: ', mult_d1_e2);
WriteLn('сумма единиц 1-го и десятков 2-го числа: ', sum_e1_d2);
end.
- 11.12.2017 06:05
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.