Вопрос по информатике:
1. Запишите значение переменной s ( по табличке), полученное в результате работы следующей программы:
s := 8;
for k := 3 to 8 do
s := s + 8;
writeln(s);
2. Написать программу,которая вычисляет сумму всех двузначных чисел
- 07.06.2018 12:40
- Информатика
- remove_red_eye 20020
- thumb_up 11
Ответы и объяснения 1
1.
s=8
k=3, s=s+8=8+8=16
k=4, s=16+8=24
k=5, s=24+8=32
k=6, s=32+8=40
k=7, s=40+8=48
k=8, s=48+8=56
Ответ: s=56
2.
var i,s:integer;
begin
s:=0;
for i:=10 to 99 do s:=s+i;
writeln('s = ',s);
end.
Результат:
s = 4905
- 08.06.2018 14:43
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.