Вопрос по информатике:
Помогите плиз решить!
1.С помощью repeat напишите программу,которая требует у вас пароль,например 111. Если пароль правильный,то заполняет все строки экрана сообщением "Молодец". Если после пятой попытки пароль всё равно неверен,выходит из программы.( я составил программу,но как ограничить её 5-ю попытками,не знаю).
2.Составьте программу,вычисляющую А*В,не пользуясь операцией умножения. А и В любое натуральное число.
3.Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу,которая рассчитывает количество бактерий на заданное вами целое значение момента времени(15 минут,7 минут и т п.)
4. В 1202г. Итальянский математик Леонард Пизанский (Фибоначчи) предложил такую
задачу: пара кроликов каждый месяц дает приплод – двух кроликов (самца и самку), от
которых через два месяца уже получается новый приплод, Сколько кроликов будет через год,
если в начале года имелась одна пара? Согласно условию задачи числа, соответствующие
количеству кроликов, которые появляются через каждый месяц, составляют
последовательность 1, 1, 2, 3, 5, 8, 13, 21, 37, … Составьте программу, позволяющую найти
все числа Фибоначчи, меньшие заданного числа N.
- 05.05.2018 00:16
- Информатика
- remove_red_eye 5137
- thumb_up 38
Ответы и объяснения 2
Вторая задача
var a,b,i,sum:integer;beginread(a,b);for i:=1 to b do begin inc(sum,a); end;writeln(sum);end.
Третья задача.
var a,b,i,sum:integer;beginwriteln('Cколько минут прошло?');read(a);sum:=1;for i:=1 to a do begin inc(sum,sum); end;writeln(sum);end.
Четвертая задача
var a,i,x:integer; fibb:array [0..1000] of integer;beginread(a);fibb[0]:=1;fibb[1]:=1;i:=2;while fibb[i-1]
- 07.05.2018 18:54
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.