Вопрос по информатике:
Напишите программу на языке Pascal печатающую все отрицательные нечетные числа, начиная с числа N (N< -100) , в обратном порядке. Пожалуйста, ребят, срочно нужна ваша помощь!!!
- 07.05.2018 22:01
- Информатика
- remove_red_eye 19015
- thumb_up 16
Ответы и объяснения 1
1. Короткий вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
Range(-99,-1,2).Print
end.
Результат
-99 -97 -95 -93 -91 -89 -87 -85 -83 -81 -79 -77 -75 -73 -71 -69 -67 -65 -63 -61 -59 -57 -55 -53 -51 -49 -47 -45 -43 -41 -39 -37 -35 -33 -31 -29 -27 -25 -23 -21 -19 -17 -15 -13 -11 -9 -7 -5 -3 -1
2. Школьный вариант
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
i:integer;
begin
i:=-99;
repeat
Write(i,' ');
i:=i+2
until i>-1
end.
- 08.05.2018 16:32
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.