Вопрос по информатике:
ПОМОГИТЕ, ПОЖАЛУЙСТА)
Составить программу вычисления функции
( Sin(x), если x<=a;
z= ( Cos(x), если a<x<b;
( Tg(x), если x>=b.
- 25.09.2017 15:27
- Информатика
- remove_red_eye 12036
- thumb_up 8
Ответы и объяснения 1
var
a, b, x, s, c, t:real;
begin
writeln('Введите a');
readln(a);
writeln('Введите b');
readln(b);
writeln('Введите x');
readln(x);
if x<=a then
begin
s:=sin(x);
writeln ('Синус равен ', s);
end
else
writeln ('Синус вычислить нельзя, так как равенство не равно ', x, '<=', a);
if (a begin c:=cos(x); writeln ('Косинус равен ', c); end else writeln ('Косинус вычислить нельзя, так как равенство не равно ', a, '<', x, '<', b); if x>=b then begin t:=tan(x); writeln ('Косинус равен ', t); end else writeln ('Косинус вычислить нельзя, так как равенство не равно ', x, '>=', b); end.
- 26.09.2017 23:43
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.