- 13.06.2016 23:26
- Информатика
- remove_red_eye 5118
- thumb_up 27
Ответы и объяснения 1
A = 2, b = 0;
Вопрос: а = 7?
Если да: Закончить.
Если нет: Прибавить к "a" единичку, а к "b" прибавить "a"
**Причем, прошу заметить, сначала мы прибавляем к "a" единичку, а потом прибавляем к "b" "a"!!! Это важно!
Поехали.
а=2, б = 0.
а = 7? нет >> а = 3, б = 3.
а = 7? нет >> а = 4, б = 7.
а = 7? нет >> а = 5, б = 12.
а = 7? нет >> а = 6, б = 18.
а = 7? нет >> а = 7, б = 25.
а = 7? Да. >> Конец.
Ответ: а = 7, б = 25.
Если просили написать программу на языке Pascal, соответствующую алгоритму:
Var a,b:integer;
Begin
a:=2;
b:=0;
while(a7) do
begin;
a:=a+1;
b:=b+a;
end;
writeln('a = ',a,' b = ',b);
readln(a);
end.
//На скриншоте результат работы данной программы
- 14.06.2016 06:04
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.