Вопрос по информатике:
Дано натуральное число. Верно ли, что сумма цифр данного числа больше А(А вводится с клавиатуры). Напишите программу Pascal, пожалуйста!
- 22.04.2017 12:05
- Информатика
- remove_red_eye 14638
- thumb_up 38
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var n:=ReadInteger('Введите число');
var a:=ReadInteger('a=');
var s:=0;
while n>0 do begin s+=n mod 10; n:=n div 10 end;
if s>a then Write('Верно') else Write('Неверно');
Writeln(', что сумма цифр числа больше ',a)
end.
Тестовое решение
Введите число 46823
a= 24
Неверно, что сумма цифр числа больше 24
- 23.04.2017 00:32
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.