Вопрос по информатике:
Составьте программу подсчета числа элементов встречающихся только в одном из массивов A(N) или B(N) ОДНОМЕРНЫЙ МАССИВ
- 22.04.2018 22:26
- Информатика
- remove_red_eye 5679
- thumb_up 13
Ответы и объяснения 1
Var i, j, kolvo:Integer; a, b:array[1..10] of Integer;begin; randomize; {Заполнение массивов} for i:=1 to 10 do begin; a[i] := random(0, 10); b[i] := random(0, 10); end; {Вывод массива a} write('Массив a = [', a[1]); for i:=2 to 10 do begin; write(', ', a[i]); end; writeln('];'); {Вывод массива b} write('Массив b = [', b[1]); for i:=2 to 10 do begin; write(', ', b[i]); end; writeln('];'); {Непосредственно нахождение кол-ва уникальных элементов} kolvo:=0; for i:=1 to 10 do begin; for j:=1 to 10 do begin; if(a[i] = b[j]) then break; if(j=10)then Inc(kolvo); end; end; for i:=1 to 10 do begin; for j:=1 to 10 do begin; if(b[i] = a[j]) then break; if(j=10)then Inc(kolvo); end; end; writeln('Количество уникальных элементов массива: ', kolvo,'.');end.
Результат:
Массив a = [8, 10, 4, 9, 0, 1, 5, 8, 9, 8];Массив b = [4, 0, 1, 5, 6, 2, 2, 1, 3, 9];Количество уникальных элементов массива: 8.
Выглядит правдоподобно, но не проверял.
- 23.04.2018 04:24
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.