Вопрос по информатике:
Программирование на C++
Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите наименьший делитель числа x, отличный от 1.
- 20.09.2017 05:28
- Информатика
- remove_red_eye 10080
- thumb_up 43
Ответы и объяснения 1
#include
int main() {
int n;
std::cin >> n;
int i = 2;
while (n % i > 0) ++i;
std::cout << i;
return 0;
}
- 21.09.2017 22:05
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.