Вопрос по информатике:
Помогите в Pascal
№4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие единицы информации.
№5. Даны длины сторон треугольника A, B, C. Найти площадь треугольника S. Составьте программу решения поставленной задачи.
, где р – полупериметр
№6. Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c).
- 01.01.2018 07:03
- Информатика
- remove_red_eye 9846
- thumb_up 37
Ответы и объяснения 1
4.
var
a:real;
begin
write('Введите количество мегабайт=');read(a);
writeln('Количество килобайт=',a*1024);
writeln('Количество байт=',a*1024*1024);
writeln('Количество бит=',a*1024*1024*8);
end.
5.
var
a,b,c,p,S:real;
begin
write('Введите сторону a=');read(a);
write('Введите сторону b=');read(b);
write('Введите сторону c=');read(c);
P:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
write('S=',s:5:2);
end.
6.
var
a:integer;
begin
write('Введите количество суток=');read(a);
writeln(24*a,' ','часов');
writeln(60*24*a,' ','минут');
writeln(60*60*24*a,' ','секунд');
end.
- 02.01.2018 15:27
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.