Вопрос по информатике:
Написать программу в Паскаль абс по теме функции.
задача: найти сумму цифр трех чисел.
- 11.04.2018 10:39
- Информатика
- remove_red_eye 8662
- thumb_up 6
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
function SoD(n:int64):integer;
begin
Result:=0;
while n>0 do begin
Result+=n mod 10;
n:=n div 10
end
end;
begin
var a:=ReadArrInteger('Введите три натуральных числа:',3);
Write('Суммы цифр чисел: '); a.Select(x->SoD(x)).Println;
Writeln('Общая сумма цифр всех чисел: ',a.Select(x->SoD(x)).Sum)
end.
Тестовое решение:
Введите три натуральных числа: 56325 23131 784545223
Суммы цифр чисел: 21 10 40
Общая сумма цифр всех чисел: 71
- 12.04.2018 03:42
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.