Вопрос по информатике:
Напишите программу на языке Pascal, которая с помощью цикла for to считала s:=1-2+3-4+5-6+7-8+9-10....
- 09.10.2015 21:12
- Информатика
- remove_red_eye 1253
- thumb_up 35
Ответы и объяснения 2
Var n,i,s:integer;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do
if i mod 2 =0 then s:=s-i else s:=s+i;
writeln('s = ',s);
end.
Пример:
n = 10
s = -5
- 01.01.1970 00:00
- thumb_up 24
Var n,s,i:integer;
begin
write('введите n ');
readln(n);
for i:=1 to n do if i mod 2 0 then s:=s+i else s:=s-i;
writeln('s = ',s);
end.
- 01.01.1970 00:00
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.