Вопрос по информатике:
(!!! СРОЧНО, МНОГО БАЛЛОВ !!!) Pascal ABC, написать программу: Дан целочисленный одномерный массив, состоящий из n элементов, и натуральные числа k, m (k МЕНЬШЕ m МЕНЬШЕ n). Вычислить среднее арифметическое элементов массива с номерами от k до m включительно.
- 10.08.2018 23:12
- Информатика
- remove_red_eye 5748
- thumb_up 15
Ответы и объяснения 1
Const n=100;
var
a: array [1,n] of integer;
sr:real; k, m, sum, i : integer;
begin
for i:= 1 to n do a[i]:=ranfom(100);
readln (k);
readln (m);
sum = 0;
for i:=k to m do
sum:=sum+a[i];
sr := sum/(m - k + 1);
writeln (sr);
end.
- 11.08.2018 00:37
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.