Вопрос по информатике:
1) Числа Фибоначчи определяются формулами: f0=f1=1; fn=fn-1+fn-2 при n =2,3,… Т.е., это последовательность вида: 1,1,2,3,5,7,…
Составить программу определения n-ого члена Фибоначчи. Вычисления суммы всех чисел Фибоначчи, которые не превосходят 1000.
Надо написать программы на языке С++.
- 27.10.2017 15:24
- Информатика
- remove_red_eye 6467
- thumb_up 14
Ответы и объяснения 1
#include
using namespace std;
int main() {
int f0=1;
int f1=1;
int s=1;
int f=1;
while (f<=1000)
{
s=s+f;
f=f0+f1;
f0=f1;
f1=f;
}
cout << "s = " << s;
}
Результат:
s = 2583
- 28.10.2017 06:55
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.