Вопрос по информатике:
СРОЧНО!!!!!! ПОМОГИТЕ!!!! Написать программу в Паскале для решения следующей задачи:вычислить и вывести на экран число и сумму положительных элементов
столбца матрицы А(15;10)
- 03.10.2017 01:08
- Информатика
- remove_red_eye 17963
- thumb_up 35
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1172
Const
n=15;
m=10;
Var
ma:array[1..n,1..m] of integer;
i,j,sum,co:integer;
begin
randomize;
writeln('Matrix:');
for i:=1 to n do
begin
for j:=1 to m do
begin
ma[i,j]:=random(10)-3;
write(ma[i,j]:4);
end;
writeln;
end;
for j:=1 to m do
begin
for i:=1 to n do
if ma[i,j]>0 then
begin
sum:=sum+ma[i,j];
inc(co);
end;
writeln('Sum ',j,':',sum);
writeln('Count ',j,':',co);
sum:=0;
co:=0;
end;
end.
- 04.10.2017 04:49
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.