Вопрос по информатике:
На Паскале.
В текстовый файл t1 записана последовательность целых чисел, разделенных пробелами.
Написать программу, записывающую в текстовый файл t2 все положительные числа из t1.
- 03.01.2016 15:54
- Информатика
- remove_red_eye 8863
- thumb_up 38
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ReadAllLines('int.txt').JoinIntoString.ToIntegers;
Print('Прочитано'); a.Println;
var b:=a.Where(x->x>0);
Print('Отобрано'); b.Println;
var f:=OpenWrite('out.txt');
foreach var e in b do Write(f,e,' ');
f.Close
end.
Тестовое решение:
Прочитано -5 8 -3 -2 0 -6 4 9 0 0 4 -4 -1 0 -1 3 6 7 1 8 0 2 -5 -2 9
Отобрано 8 4 9 4 3 6 7 1 8 2 9
- 04.01.2016 04:37
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.