Вопрос по информатике:
Даны числа n и m. Создайте массив A[n][m] и заполните его, как показано на примере. Входные данные
Программа получает на вход два числа n и m.
Выходные данные
Программа должна вывести полученный массив.
Примеры
входные данные
4 10
выходные данные
0 1 3 6 10 14 18 22 26 30
2 4 7 11 15 19 23 27 31 34
5 8 12 16 20 24 28 32 35 37
9 13 17 21 25 29 33 36 38 39 PASCAL
- 03.07.2018 06:11
- Информатика
- remove_red_eye 6672
- thumb_up 19
Ответы и объяснения 1
Var mas:array[1..100,1..100] of integer;
N,M,D,N2,i,C,j,M2,k:integer;
begin
N:=0;D:=0;k:=0;
write('Введите N = ');Readln(N);
write('Введите M = ');Readln(M);
For i:= 1 to M do begin
M2:=1;
For N2:=i downto 1 do begin
if M2<=N then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
//после побочной диагонали
For D:=2 to N do begin
M2:=D;
For N2:=M downto 1 do begin
IF (M2<=N) and (N2<=M) then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
For i:=1 to N do begin Writeln();
for j:=1 to M do
write(mas[i,j],' ');
end;
end.
- 04.07.2018 08:45
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.